<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
    <title>Positions the Broncos should be looking to upgrade this offseason</title>
    <meta charset="UTF-8" />
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://milehighsports.com/xmlrpc.php" />
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-KBQZ83"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KBQZ83');</script>
<!-- End Google Tag Manager -->
<!-- begin Twitter card-->
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:site" content="@milehighsports">
<meta name="twitter:title" content="">
<meta name="twitter:description" content="">
<meta name="twitter:image" content="">
<!-- end Twitter card-->
<!-- START CONTENT.AD VIDEO -->
<script async="true" src="//pmpubs.com/ps?cfg=56876294&sid=milehighsports"></script>
<!-- END CONTENT.AD VIDEO -->
<!-- Start Alexa Certify Javascript -->
<script type="text/javascript">
_atrk_opts = { atrk_acct:"Wltjn1aMp410vg", domain:"milehighsports.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://d31qbv1cthcecs.cloudfront.net/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=Wltjn1aMp410vg" style="display:none" height="1" width="1" alt="" /></noscript>
<!-- End Alexa Certify Javascript -->  
<!--BEGIN Adsense PageLevel Ad-->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-5774454645204961",
    enable_page_level_ads: true
  });
</script>
<!--END Adsense PageLevel Ad-->

<!--BEGIN GOOGLE DFP Tag-->
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/65792806/300-250_1', [300, 250], 'div-gpt-ad-1483478416183-0').addService(googletag.pubads());
    googletag.defineSlot('/65792806/300-250_3', [300, 250], 'div-gpt-ad-1483478416183-1').addService(googletag.pubads());
    googletag.defineSlot('/65792806/728-90_1', [[655, 81], [728, 90]], 'div-gpt-ad-1483478416183-2').addService(googletag.pubads());
    googletag.defineSlot('/65792806/728-90_2', [655, 81], 'div-gpt-ad-1483478416183-3').addService(googletag.pubads());
    googletag.defineSlot('/65792806/300-250_5', [300, 250], 'div-gpt-ad-1483478416183-4').addService(googletag.pubads());
    googletag.defineSlot('/65792806/Broncos_Sponsorship', [655, 81], 'div-gpt-ad-1483478416183-5').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<!--END GOOGLE DFP Tag-->
	  
    <meta property="og:image" content="http://milehighsports.com/wp-content/uploads/2017/02/Russell-Okung.jpg" /><meta name="author" content="Clint Daly">
<link rel="icon" type="image/png" href="http://milehighsports.com/wp-content/uploads/2015/09/favicon.ico">
<!-- This site is optimized with the Yoast SEO plugin v4.2.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Likely to have 10 draft picks and around $33 million dollars to spend, which positions are the Broncos going to be looking to upgrade?"/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="http://milehighsports.com/positions-broncos-looking-upgrade-offseason/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Positions the Broncos should be looking to upgrade this offseason" />
<meta property="og:description" content="Likely to have 10 draft picks and around $33 million dollars to spend, which positions are the Broncos going to be looking to upgrade?" />
<meta property="og:url" content="http://milehighsports.com/positions-broncos-looking-upgrade-offseason/" />
<meta property="og:site_name" content="Mile High Sports" />
<meta property="article:publisher" content="https://facebook.com/milehighsports" />
<meta property="article:tag" content="A.J. Derby" />
<meta property="article:tag" content="Brandon Marshall" />
<meta property="article:tag" content="Brandon Williams" />
<meta property="article:tag" content="Cam Robinson" />
<meta property="article:tag" content="Corey Nelson" />
<meta property="article:tag" content="Donald Stephenson" />
<meta property="article:tag" content="Dontari Poe" />
<meta property="article:tag" content="Evan Engram" />
<meta property="article:tag" content="Jeff Heuerman" />
<meta property="article:tag" content="John Elway" />
<meta property="article:tag" content="Jonathan Allen" />
<meta property="article:tag" content="Josh McCown" />
<meta property="article:tag" content="Kawann Short" />
<meta property="article:tag" content="Martellus Bennett" />
<meta property="article:tag" content="Matt Barkley" />
<meta property="article:tag" content="Matt McGloin" />
<meta property="article:tag" content="Mike McCoy" />
<meta property="article:tag" content="O.J. Howard" />
<meta property="article:tag" content="Paxton Lynch" />
<meta property="article:tag" content="Russell Okung" />
<meta property="article:tag" content="Ryan Ramcyzk" />
<meta property="article:tag" content="Sylvester Williams" />
<meta property="article:tag" content="TJ Yates" />
<meta property="article:tag" content="Todd Davis" />
<meta property="article:tag" content="Trevor Siemian" />
<meta property="article:tag" content="Trey Burton" />
<meta property="article:tag" content="Virgil Green" />
<meta property="article:tag" content="Zach Cunningham" />
<meta property="article:section" content="Broncos" />
<meta property="article:published_time" content="2017-02-10T09:00:22-07:00" />
<meta property="article:modified_time" content="2017-02-10T09:01:59-07:00" />
<meta property="og:updated_time" content="2017-02-10T09:01:59-07:00" />
<meta property="og:image" content="http://milehighsports.com/wp-content/uploads/2017/02/Russell-Okung.jpg" />
<meta property="og:image:width" content="900" />
<meta property="og:image:height" content="600" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Likely to have 10 draft picks and around $33 million dollars to spend, which positions are the Broncos going to be looking to upgrade?" />
<meta name="twitter:title" content="Positions the Broncos should be looking to upgrade this offseason" />
<meta name="twitter:site" content="@MileHighSports" />
<meta name="twitter:image" content="http://milehighsports.com/wp-content/uploads/2017/02/Russell-Okung.jpg" />
<meta name="twitter:creator" content="@MileHighSports" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Mile High Sports &raquo; Feed" href="http://milehighsports.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mile High Sports &raquo; Comments Feed" href="http://milehighsports.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mile High Sports &raquo; Positions the Broncos should be looking to upgrade this offseason Comments Feed" href="http://milehighsports.com/positions-broncos-looking-upgrade-offseason/feed/" />
		<script type="text/javascript">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</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='opinionstage-style-css'  href='http://milehighsports.com/wp-content/plugins/social-polls-by-opinionstage/opinionstage-style-common.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='opinionstage-font-style-css'  href='http://milehighsports.com/wp-content/plugins/social-polls-by-opinionstage/opinionstage-font.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='http://milehighsports.com/wp-includes/css/dashicons.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='menu-icons-extra-css'  href='http://milehighsports.com/wp-content/plugins/menu-icons/css/extra.css?ver=0.10.2' type='text/css' media='all' />
<link rel='stylesheet' id='nks_cc_styles-css'  href='http://milehighsports.com/wp-content/plugins/NKS-custom/css/nks-custom.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://milehighsports.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='popup-maker-site-css'  href='http://milehighsports.com/wp-content/plugins/popup-maker/assets/css/site.css?ver=1.4.21' type='text/css' media='all' />
<link rel='stylesheet' id='theiaPostSlider-css'  href='http://milehighsports.com/wp-content/plugins/theia-post-slider/css/font-theme.css?ver=1.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='theiaPostSlider-font-css'  href='http://milehighsports.com/wp-content/plugins/theia-post-slider/fonts/style.css?ver=1.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_open_sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='http://fonts.googleapis.com/css?family=Arvo%3A400%2C700%7CLato%3A400%2C700&#038;ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://milehighsports.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.12' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://milehighsports.com/wp-content/themes/Newspaper/style.css?ver=7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wpsimplegallery-style-css'  href='http://milehighsports.com/wp-content/plugins/wp-simple-galleries/wp-simple-gallery.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='colorbox-css'  href='http://milehighsports.com/wp-content/plugins/wp-simple-galleries/colorbox/themes/theme1/colorbox.css?ver=4.7.2' type='text/css' media='all' />
<script type='text/javascript' src='http://milehighsports.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://milehighsports.com/wp-includes/js/jquery/jquery-migrate.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var NKS_CC_Opts = {"test_mode":"","sidebar_type":"slide","sidebar_pos":"left","width":"200","base_color":"#000000","fade_content":"light","label_top":"0%","label_top_mob":"0px","label_size":"2x","label_vis":"visible","label_invert":"","label_no_anim":"","label_scroll_selector":"","selectors":"","bg":"none","path":"http:\/\/milehighsports.com\/wp-content\/plugins\/NKS-custom\/img\/"};
/* ]]> */
</script>
<script type='text/javascript' src='http://milehighsports.com/wp-content/plugins/NKS-custom/js/nks-custom.min.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://milehighsports.com/wp-content/plugins/theia-post-slider/js/balupton-history.js/jquery.history.js?ver=1.7.1'></script>
<script type='text/javascript' src='http://milehighsports.com/wp-content/plugins/theia-post-slider/js/async.min.js?ver=14.09.2014'></script>
<script type='text/javascript' src='http://milehighsports.com/wp-content/plugins/theia-post-slider/js/hammer.min.js?ver=2.0.4'></script>
<script type='text/javascript' src='http://milehighsports.com/wp-content/plugins/theia-post-slider/js/tps.js?ver=1.9.3'></script>
<script type='text/javascript' src='http://milehighsports.com/wp-content/plugins/theia-post-slider/js/tps-transition-slide.js?ver=1.9.3'></script>
<script type='text/javascript' src='http://milehighsports.com/wp-content/plugins/advanced-ads-responsive/public/assets/js/script.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://milehighsports.com/wp-content/plugins/wp-simple-galleries/colorbox/jquery.colorbox-min.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://milehighsports.com/wp-content/plugins/wp-simple-galleries/wp-simple-gallery.js?ver=4.7.2'></script>
<link rel='https://api.w.org/' href='http://milehighsports.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://milehighsports.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://milehighsports.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.2" />
<link rel='shortlink' href='http://milehighsports.com/?p=97774' />
<link rel="alternate" type="application/json+oembed" href="http://milehighsports.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fmilehighsports.com%2Fpositions-broncos-looking-upgrade-offseason%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://milehighsports.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fmilehighsports.com%2Fpositions-broncos-looking-upgrade-offseason%2F&#038;format=xml" />
    <style id="pum-styles" type="text/css">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</style>		<style>
			.theiaPostSlider_nav.fontTheme ._title,
			.theiaPostSlider_nav.fontTheme ._text {
				line-height: 48px;
			}

			.theiaPostSlider_nav.fontTheme ._button {
				color: #bb352c;
			}

			.theiaPostSlider_nav.fontTheme ._button ._2 span {
				font-size: 48px;
				line-height: 48px;
			}

			.theiaPostSlider_nav.fontTheme ._button:hover,
			.theiaPostSlider_nav.fontTheme ._button:focus {
				color: #d75f57;
			}

			.theiaPostSlider_nav.fontTheme ._disabled {
				color: #727272 !important;
			}
		</style>
	<!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://milehighsports.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://milehighsports.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><link rel="amphtml" href="http://milehighsports.com/positions-broncos-looking-upgrade-offseason/amp/" />
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_animation_stack_effect="type0";
var tds_animation_stack=true;
var td_animation_stack_specific_selectors=".entry-thumb, img";
var td_animation_stack_general_selectors=".td-animation-stack img, .post img";
var td_ajax_url="http:\/\/milehighsports.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.2";
var td_get_template_directory_uri="http:\/\/milehighsports.com\/wp-content\/themes\/Newspaper";
var tds_snap_menu="snap";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="7";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#bb352c";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>

<script type='text/javascript'>
  (function() {
    var useSSL = 'https:' == document.location.protocol;
    var src = (useSSL ? 'https:' : 'http:') +
        '//www.googletagservices.com/tag/js/gpt.js';
    document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
  })();
</script>

<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/65792806/Rockies_Sponsorship', [655, 81], 'div-gpt-ad-1467907643024-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.pubads().enableSyncRendering();
    googletag.enableServices();
  });
</script><script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-20825277-1', 'auto');
  ga('send', 'pageview');

</script><noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>
<style type="text/css" id="nks-dynamic-styles">
@font-face {
	font-family: 'FontAwesome';
	src: url('http://milehighsports.com/wp-content/plugins/NKS-custom/fonts/fontawesome-webfont.eot?v=4.1.0');
	src: url('http://milehighsports.com/wp-content/plugins/NKS-custom/fonts/fontawesome-webfont.eot?#iefix&v=4.1.0') format('embedded-opentype'),
	url('http://milehighsports.com/wp-content/plugins/NKS-custom/fonts/fontawesome-webfont.svg?v=4.1.0#fontawesomeregular') format('svg'),
	url('http://milehighsports.com/wp-content/plugins/NKS-custom/fonts/fontawesome-webfont.woff?v=4.1.0') format('woff'),
	url('http://milehighsports.com/wp-content/plugins/NKS-custom/fonts/fontawesome-webfont.ttf?v=4.1.0') format('truetype');
	font-weight: normal;
	font-style: normal
}

	
	

		#nks_cc_sidebar {
		width: 200px;
		overflow: hidden;
	}
	#nks_cc_sidebar .nks_cc_sidebar_cont_scrollable {
		width: 200px !important;
		padding-right: 60px;
	}

	#nks_cc_sidebar .nks_cc_sidebar_cont {
		width: 200px !important;
	}

	body #nks_cc_sidebar {
		-webkit-transform: translate(-200px,0);
		-moz-transform: translate(-200px,0);
		-ms-transform: translate(-200px,0);
		-o-transform: translate(-200px,0);
		transform: translate(-200px,0);
		-webkit-transform: translate3d(-200px,0,0);
		-moz-transform: translate3d(-200px,0,0);
		-ms-transform: translate3d(-200px,0,0);
		-o-transform: translate3d(-200px,0,0);
		transform: translate3d(-200px,0,0);
	}

	body.nks_cc_sidebar_pos_right #nks_cc_sidebar  {
		-webkit-transform: translate(200px,0);
		-moz-transform: translate(200px,0);
		-ms-transform: translate(200px,0);
		-o-transform: translate(200px,0);
		transform: translate(200px,0);
		-webkit-transform: translate3d(200px,0,0);
		-moz-transform: translate3d(200px,0,0);
		-ms-transform: translate3d(200px,0,0);
		-o-transform: translate3d(200px,0,0);
		transform: translate3d(200px,0,0);
	}

	body.nks_cc_exposed > .nks_cc_trigger_tabs {
		-webkit-transform: translate(200px,0);
		-moz-transform: translate(200px,0);
		-ms-transform: translate(200px,0);
		-o-transform: translate(200px,0);
		transform: translate(200px,0);
		-webkit-transform: translate3d(200px,0,0);
		-moz-transform: translate3d(200px,0,0);
		-ms-transform: translate3d(200px,0,0);
		-o-transform: translate3d(200px,0,0);
		transform: translate3d(200px,0,0);
	}

	body.nks_cc_sidebar_pos_right.nks_cc_exposed > .nks_cc_trigger_tabs  {
		-webkit-transform: translate(-200px,0);
		-moz-transform: translate(-200px,0);
		-ms-transform: translate(-200px,0);
		-o-transform: translate(-200px,0);
		transform: translate(-200px,0);
		-webkit-transform: translate3d(-200px,0,0);
		-moz-transform: translate3d(-200px,0,0);
		-ms-transform: translate3d(-200px,0,0);
		-o-transform: translate3d(-200px,0,0);
		transform: translate3d(-200px,0,0);
	}

	
	.nks_cc_exposed #nks-overlay {
	    opacity: 0.3;
		-ms-filter: "progid:DXImageTransform.Microsoft.Alpha(Opacity=30)";
	}

		.nks_cc_exposed #nks-overlay:hover {
		cursor: pointer;
		cursor: url("http://milehighsports.com/wp-content/plugins/NKS-custom/img/close2.png") 16 16,pointer;
	}
	
#nks_cc_sidebar {
		background-color: #000000 !important;
}

	.nks_cc_trigger_tabs #nks-tab-1 .fa:before  {
					color: #000000;
	      }.nks_cc_trigger_tabs.nks_metro  #nks-tab-1 .fa-stack-2x {
					background-color: #000000;
	      }#nks-content-1 {
					background-color: #000000 !important;
	      }	
.nks_cc_imagebg_custom {
		background-image: url() !important;
}



	#nks_cc_sidebar .nks-content > div {
		-webkit-transition: -webkit-transform 0.4s ease-in-out 0.2s;
		-moz-transition: -moz-transform 0.4s ease-in-out 0.2s;
		-ms-transition: -ms-transform 0.4s ease-in-out 0.2s;
		-o-transition: -o-transform 0.4s ease-in-out 0.2s;
		transition: transform 0.4s ease-in-out;
		-webkit-backface-visibility: hidden;
	}
	#nks_cc_sidebar .nks-content > div.nks-shrinked {
    -webkit-transform: scale(0.9, 0.9) !important;
    -moz-transform:  scale(0.9, 0.9) !important;
    -ms-transform:  scale(0.9, 0.9) !important;
    transform:  scale(0.9, 0.9) !important;
    -webkit-transform-origin: top center;
		-moz-transform-origin: top center;
		-ms-transform-origin: top center;
		transform-origin: top center;
}


	.nks_mobile .nks_cc_trigger_tabs {
		top: 0px !important;
	}

#cssmenu {
 background: #000;  
list-style: none;
text-align: left;
font-size: 16px;

  margin: 0;
  padding-left: 30px;
  width: 100%;

}
#cssmenu li {
  margin: 0;
  padding: 0;
  list-style: none;
line-height: 27px;
}
#cssmenu a {
  background: #000;

  color: #fff;

  margin: 0;
  padding: 8px 12px;
  text-decoration: none;
  font-weight: normal;

}
#cssmenu a:hover {

  color: #5BABFF;
  padding-bottom: 8px;
width: 100%;
}

</style>

<div id="nks_cc_sidebar" class="nks_cc_imagebg_none">
	<div class="nks_cc_sidebar_cont_scrollable">
		<div class="nks_cc_sidebar_cont">

			<div id='nks-content-1' class='nks-content'><div class='nks-shrinked'><br/>
<div id="cssmenu">
<ul>
<li class="active"><a href=/current-issue/><span>Magazine</span></a></li>
<li><a href=/subscribe/><span>Subscribe</span></a></li>
<li><a href=/lineup/><span>Radio Lineup</span></a></li>
<li><a href=http://v6.player.abacast.net/3526 target="_blank"><span>Listen Live</span></a></li>
<li><a href=/podcasts/><span>Podcasts</span></a></li>
<li><a href=/video/><span>Video</span></a></li>
<li><a href=/daily-column/><span>Daily Column</span></a></li>
<li><a href=/subscribe-daily/><span>Daily Signup</span></a></li>
<br/>
<li><a href=/broncos/><span>Broncos</span></a></li>
<li><a href=/rockies/><span>Rockies</span></a></li>
<li><a href=/nuggets/><span>Nuggets</span></a></li>
<li><a href=/avalanche/><span>Avalanche</span></a></li>
<li><a href=/rapids/><span>Rapids</span></a></li>
<li><a href=/buffs/><span>Buffs</span></a></li>
<li><a href=/rams/><span>Rams</span></a></li>
<li><a href=/college/><span>College</span></a></li>
<li><a href=/preps/><span>Preps</span></a></li>
<li><a href=/other/><span>Other</span></a></li>
<br/>
<li><a href=/contact/><span>Contact</span></a></li>
<li><a href=/careers/><span>Employment</span></a></li>
<li><a href=/equal-employment-opportunity/><span>EEO Policy</span></a></li>
<li><a href=/mhs-contest-rules/><span>Contest Rules</span></a></li>
<li class="last"><a href=/privacy-policy/><span>Privacy Policy</span></a></li>
<br/>
<h6><span style="color: #999999;">@2017 Mile High Sports</span>
<br/>
<span style="color: #999999;">All photos courtesy of USA Today Sports Images unless otherwise noted.</span></h6>
</ul>
</div></div></div>		</div>
	</div>
</div>

<div class="nks_cc_trigger_tabs nks_cc_label_visible nks_metro" style="top:0%"><span id="nks-tab-1" class="nks-tab fa-stack fa-lg fa-2x"> <i class="fa fa-circle fa-stack-2x "></i> <i class="fa fa-bars fa-stack-1x fa-inverse"></i> </span></div><div id="nks-body-bg"></div>
<div id="nks-overlay-wrapper"><div id="nks-overlay"></div></div>
<script>
	(function($){
		if (!$ || !window.NKS_CC_Opts) return;

		var TYPE = NKS_CC_Opts.sidebar_type;
		var $bodybg = $('#nks-body-bg');
		var b = document.body;
		var $body = $('body');
		var bodyCss;

    // fix onload
		$(function(){
			setTimeout(function(){

				if (!$bodybg.parent().is($body)) {
					$body.prepend($bodybg).prepend($('.nks_cc_trigger_tabs')).prepend($('#nks_cc_sidebar')).append($('#nks-overlay-wrapper'));
				}

				if (TYPE === 'push') { $bodybg.css('backgroundColor', $body.css('backgroundColor')) }

			},0)
		})

		if (TYPE === 'push') {

			bodyCss = {
				'backgroundColor':$body.css('backgroundColor'),
				'backgroundImage':$body.css('backgroundImage'),
				'backgroundAttachment':$body.css('backgroundAttachment'),
				'backgroundSize':$body.css('backgroundSize'),
				'backgroundPosition':$body.css('backgroundPosition'),
				'backgroundRepeat':$body.css('backgroundRepeat'),
				'backgroundOrigin':$body.css('backgroundOrigin'),
				'backgroundClip':$body.css('backgroundClip')
			};

			if (bodyCss.backgroundColor.indexOf('(0, 0, 0, 0') + 1 || bodyCss.backgroundColor.indexOf('transparent') + 1 ) {
				bodyCss.backgroundColor = '#fff';
			}

			if (bodyCss.backgroundAttachment === 'fixed') {
				NKS_CC_Opts.isBgFixed = true;
				bodyCss.position = 'fixed';
				bodyCss.bottom = 0;
				bodyCss.backgroundAttachment = 'scroll';
			} else {
//				bodyCss.height = Math.max(
//					b.scrollHeight, document.documentElement.scrollHeight,
//					b.offsetHeight, document.documentElement.offsetHeight,
//					b.clientHeight, document.documentElement.clientHeight
//				)
			}

			$bodybg.css(bodyCss);

		} else {
			//$body.addClass('nks_sidebar_slide')
		}

	})(window.jQuery)
</script>



</head>


<body class="post-template-default single single-post postid-97774 single-format-standard positions-broncos-looking-upgrade-offseason wpb-js-composer js-comp-ver-4.12 vc_responsive td-animation-stack-type0 td-boxed-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">


<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

<div id="td-outer-wrap">

    <div class="td-transition-content-and-menu td-mobile-nav-wrap">
        <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/milehighsports" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://soundcloud.com/milehighsports" title="Soundcloud">
                <i class="td-icon-font td-icon-soundcloud"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/milehighsports" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-mhs-main-container"><ul id="menu-mhs-main" class="td-mobile-main-menu"><li id="menu-item-62298" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first menu-item-62298"><a href="http://milehighsports.com/subscribe/">SUBSCRIBE</a></li>
<li id="menu-item-62137" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62137"><a target="_blank" href="http://v6.player.abacast.net/3526">LISTEN LIVE</a></li>
<li id="menu-item-61610" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61610"><a href="http://milehighsports.com/broncos/"><img width="40" height="40" src="http://milehighsports.com/wp-content/uploads/2015/09/broncs40.png" class="_mi _image" alt="" aria-hidden="true" style="vertical-align:baseline;" /><span class="visuallyhidden">Broncos</span></a></li>
<li id="menu-item-61609" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61609"><a href="http://milehighsports.com/rockies/"><img width="40" height="40" src="http://milehighsports.com/wp-content/uploads/2015/09/roxs40.png" class="_mi _image" alt="" aria-hidden="true" style="vertical-align:baseline;" /><span class="visuallyhidden">Rockies</span></a></li>
<li id="menu-item-61633" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61633"><a href="http://milehighsports.com/nuggets/"><img width="40" height="40" src="http://milehighsports.com/wp-content/uploads/2015/09/nugs40.png" class="_mi _image" alt="" aria-hidden="true" style="vertical-align:baseline;" /><span class="visuallyhidden">Nuggets</span></a></li>
<li id="menu-item-61632" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61632"><a href="http://milehighsports.com/avalanche/"><img width="40" height="40" src="http://milehighsports.com/wp-content/uploads/2015/09/avs40.png" class="_mi _image" alt="" aria-hidden="true" style="vertical-align:baseline;" /><span class="visuallyhidden">Avalanche</span></a></li>
<li id="menu-item-61631" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61631"><a href="http://milehighsports.com/rapids/"><img width="40" height="40" src="http://milehighsports.com/wp-content/uploads/2015/09/raps40.png" class="_mi _image" alt="" aria-hidden="true" style="vertical-align:baseline;" /><span class="visuallyhidden">Rapids</span></a></li>
<li id="menu-item-83853" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-83853"><a href="http://milehighsports.com/buffs/"><img width="40" height="40" src="http://milehighsports.com/wp-content/uploads/2015/09/buffs40.png" class="_mi _image" alt="" aria-hidden="true" style="vertical-align:baseline;" /><span class="visuallyhidden">Buffs</span></a></li>
<li id="menu-item-83854" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-83854"><a href="http://milehighsports.com/rams/"><img width="40" height="40" src="http://milehighsports.com/wp-content/uploads/2015/09/rams40.png" class="_mi _image" alt="" aria-hidden="true" style="vertical-align:baseline;" /><span class="visuallyhidden">Rams</span></a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    </div>

        <div class="td-transition-content-and-menu td-content-wrap">



<!--
Header style 7
-->

<div class="td-header-wrap td-header-style-7">
        <div class="td-header-top-menu-full">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Friday, February 10, 2017
            </div>
        </div>
    </div>
        <div class="td-header-sp-top-widget">
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/milehighsports" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://soundcloud.com/milehighsports" title="Soundcloud">
                <i class="td-icon-font td-icon-soundcloud"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/milehighsports" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div>
    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <ul class="td-login-tabs">
                        <li><a id="login-link" class="td_login_tab_focus">LOG IN</a></li>
                    </ul>



                    <div class="td-login-wrap">
                        <div class="td_display_err"></div>

                        <div id="td-login-div" class="">
                            <div class="td-login-panel-title">Welcome! Log into your account</div>
                            <input class="td-login-input" type="text" name="login_email" id="login_email" placeholder="your username" value="" required>
                            <input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" placeholder="your password" required>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Log In">


                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password?</a></div>


                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-display-none">
                            <div class="td-login-panel-title">Recover your password</div>
                            <input class="td-login-input" type="text" name="forgot_email" id="forgot_email" placeholder="your email" value="" required>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Pass">
                        </div>




                    </div>
                </div>
                        </div>
    </div>
    
    <div class="td-header-menu-wrap-full">
        <div class="td-header-menu-wrap td-header-gradient">
            <div class="td-container td-header-row td-header-main-menu">
                <div class="td-header-sp-logo">
                            <a class="td-main-logo" href="http://milehighsports.com/">
            <img class="td-retina-data" data-retina="http://milehighsports.com/wp-content/uploads/2015/09/mhs_logo_sm.png" src="http://milehighsports.com/wp-content/uploads/2015/09/mhs_logo_xsm.png" alt=""/>
           
        </a>
                    </div>
                    <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
        		<a class="td-mobile-logo td-sticky-header" href="http://milehighsports.com/">
			<img class="td-retina-data" data-retina="http://milehighsports.com/wp-content/uploads/2015/09/mhs_logo_xsm_wt.png" src="http://milehighsports.com/wp-content/uploads/2015/09/mhs_logo_xsm_wt.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-header" href="http://milehighsports.com/">
			<img class="td-retina-data" data-retina="http://milehighsports.com/wp-content/uploads/2015/09/mhs_logo_sm.png" src="http://milehighsports.com/wp-content/uploads/2015/09/mhs_logo_xsm.png" alt=""/>
		</a>
	    </div>
    <div class="menu-mhs-main-container"><ul id="menu-mhs-main-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-62298"><a href="http://milehighsports.com/subscribe/">SUBSCRIBE</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-62137"><a target="_blank" href="http://v6.player.abacast.net/3526">LISTEN LIVE</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-61610"><a href="http://milehighsports.com/broncos/"><img width="40" height="40" src="http://milehighsports.com/wp-content/uploads/2015/09/broncs40.png" class="_mi _image" alt="" aria-hidden="true" style="vertical-align:baseline;" /><span class="visuallyhidden">Broncos</span></a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-61609"><a href="http://milehighsports.com/rockies/"><img width="40" height="40" src="http://milehighsports.com/wp-content/uploads/2015/09/roxs40.png" class="_mi _image" alt="" aria-hidden="true" style="vertical-align:baseline;" /><span class="visuallyhidden">Rockies</span></a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-61633"><a href="http://milehighsports.com/nuggets/"><img width="40" height="40" src="http://milehighsports.com/wp-content/uploads/2015/09/nugs40.png" class="_mi _image" alt="" aria-hidden="true" style="vertical-align:baseline;" /><span class="visuallyhidden">Nuggets</span></a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-61632"><a href="http://milehighsports.com/avalanche/"><img width="40" height="40" src="http://milehighsports.com/wp-content/uploads/2015/09/avs40.png" class="_mi _image" alt="" aria-hidden="true" style="vertical-align:baseline;" /><span class="visuallyhidden">Avalanche</span></a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-61631"><a href="http://milehighsports.com/rapids/"><img width="40" height="40" src="http://milehighsports.com/wp-content/uploads/2015/09/raps40.png" class="_mi _image" alt="" aria-hidden="true" style="vertical-align:baseline;" /><span class="visuallyhidden">Rapids</span></a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-83853"><a href="http://milehighsports.com/buffs/"><img width="40" height="40" src="http://milehighsports.com/wp-content/uploads/2015/09/buffs40.png" class="_mi _image" alt="" aria-hidden="true" style="vertical-align:baseline;" /><span class="visuallyhidden">Buffs</span></a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-83854"><a href="http://milehighsports.com/rams/"><img width="40" height="40" src="http://milehighsports.com/wp-content/uploads/2015/09/rams40.png" class="_mi _image" alt="" aria-hidden="true" style="vertical-align:baseline;" /><span class="visuallyhidden">Rams</span></a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="http://milehighsports.com/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full">
        <div class="td-container-header td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    
</div>            </div>
        </div>
    </div>

</div><div class="td-main-content-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-97774" class="post-97774 post type-post status-publish format-standard has-post-thumbnail hentry category-denver-broncos category-top-stories tag-a-j-derby tag-brandon-marshall tag-brandon-williams tag-cam-robinson tag-corey-nelson tag-donald-stephenson tag-dontari-poe tag-evan-engram tag-jeff-heuerman tag-john-elway tag-jonathan-allen tag-josh-mccown tag-kawann-short tag-martellus-bennett tag-matt-barkley tag-matt-mcgloin tag-mike-mccoy tag-o-j-howard tag-paxton-lynch tag-russell-okung tag-ryan-ramcyzk tag-sylvester-williams tag-tj-yates tag-todd-davis tag-trevor-siemian tag-trey-burton tag-virgil-green tag-zach-cunningham" itemscope itemtype="http://schema.org/Article">
        <div class="td-post-header">

            <ul class="td-category"><li class="entry-category"><a  style="background-color:#000000; color:#fff; border-color:#000000;" href="http://milehighsports.com/category/teams/denver-broncos/">Broncos</a></li><li class="entry-category"><a  href="http://milehighsports.com/category/top-stories/">Top Story</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Positions the Broncos should be looking to upgrade this offseason</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name">By <a href="http://milehighsports.com/author/cdaly/">Clint Daly</a> - </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-02-10T09:00:22+00:00" >February 10, 2017</time></span>                                        <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-97774">7</span></div>                </div>

            </header>

        </div>

        

        <div class="td-post-content">

        <div class="td-post-featured-image"><img width="696" height="464" class="entry-thumb" src="http://milehighsports.com/wp-content/uploads/2017/02/Russell-Okung-696x464.jpg" alt="" title="Russell Okung"/></div>
        <div class="td-a-rec td-a-rec-id-content_top  "><!-- /65792806/728-90_1 -->
<div id='div-gpt-ad-1483478416183-2'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1483478416183-2'); });
</script>
</div></div><div id="tps_slideContainer_97774" class="theiaPostSlider_slides"><div>

<p>The 2016 NFL season is now officially in the books, and we can begin looking forward to how the Broncos are going to improve in the offseason. Despite going 9-7, there is reason to believe that this team can return to Super Bowl contention with the correct adjustments. <a href="http://www.pro-football-reference.com/players/E/ElwaJo00.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">John Elway</a> is already targeting players, in both the draft and free agency, that can get this team back into postseason play.</p>
<p>Likely to have 10 draft picks and around $33 million dollars to spend, which positions are the Broncos going to be looking to upgrade?</p>
<h2><strong>Offensive tackle</strong></h2>
<p>This may be the most obvious, as both of the Broncos&#8217; offensive tackles struggled all season, but it won&#8217;t be that easy. <a href="http://www.pro-football-reference.com/players/S/StepDo00.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Donald Stephenson</a> still has two years left on his current contract, and his release would leave $2 million in dead money. <a href="http://www.pro-football-reference.com/players/O/OkunRu20.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Russell Okung</a> is due to receive a sizeable bonus if he isn&#8217;t released, but that is a realistic option, as there would only be $800,000 in dead money. So, <a href="http://www.sports-reference.com/cfb/players/john-elway-1.html?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">John Elway</a> is going to have some decisions to make before he can even begin to look elsewhere.</p>
<p>The free agent crop of offensive tackles is a little sparse this season, with the best prospects being either past their prime, or injury prone. The Broncos could be forced to look in the NFL Draft to upgrade the position. Alabama’s <a href="http://www.sports-reference.com/cfb/players/cam-robinson-2.html?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Cam Robinson</a> or Wisconsin’s Ryan Ramcyzk are possibilities, but they will need some time to develop.</p>
<h2><strong>A veteran quarterback</strong></h2>
<p>New head coach <a href="http://www.pro-football-reference.com/players/J/JoseVa20.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Vance Joseph</a> has stated that the quarterback competition is open, and that either <a href="http://www.pro-football-reference.com/players/S/SiemTr00.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Trevor Siemian</a> or <a href="http://www.pro-football-reference.com/players/L/LyncPa00.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Paxton Lynch</a> will be the Broncos starter in 2017. Joseph and offensive coordinator <a href="http://www.pro-football-reference.com/search/search.fcgi?pid=McCoMi21,McCoMi22&amp;search=Mike+McCoy&amp;utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Mike McCoy</a> have both also said that they are content with their quarterbacks.</p>
<p>Still, it&#8217;s a very inexperienced group, and the Broncos could still look for a veteran backup. <a href="http://www.pro-football-reference.com/players/B/BarkMa00.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Matt Barkley</a>, <a href="http://www.pro-football-reference.com/players/M/McCoJo01.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Josh McCown</a> and TJ Yates aren’t going to be a threat for a starting spot, but they could hold a clipboard, and mentor these young guys. There is one name out there that the Broncos could be interested in, and he could come in and compete for the starting job. Don’t forget that quarterbacks coach <a href="http://www.pro-football-reference.com/players/M/MusgBi00.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Bill Musgrave</a> did spend time with 27-year-old <a href="http://www.pro-football-reference.com/players/M/McGlMa01.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Matt McGloin</a> when both were with the Oakland Raiders.</p>
<h2><strong>Nose tackle</strong></h2>
<p>We all saw that <a href="http://www.pro-football-reference.com/players/W/WillSy00.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Sylvester Williams</a> struggled to man the middle last season, after the departure of <a href="http://www.pro-football-reference.com/players/J/JackMa02.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Malik Jackson</a> to the Jaguars. He logged only 29 tackles, and just one single sack. Williams is set to become a free agent this spring.</p>
<p>If there is one position that is deep with available players in free agency, its nose tackle. <a href="http://www.pro-football-reference.com/players/S/ShorKa00.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Kawann Short</a>, <a href="http://www.pro-football-reference.com/search/search.fcgi?pid=WillBr02,WillBr04,WillBr01,WillBr07,WillBr95&amp;search=Brandon+Williams&amp;utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Brandon Williams</a>, and <a href="http://www.pro-football-reference.com/players/P/PoexDo00.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Dontari Poe</a> are all set to become unrestricted free agents in March. The NFL Draft will feature top prospect <a href="http://www.sports-reference.com/cfb/players/jonathan-allen-1.html?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Jonathan Allen</a> from Alabama, but he is likely a top-10 pick, that might be difficult for the Broncos to attain.</p>
<h2><strong>Tight end</strong></h2>
<p>I think it is safe to assume that the Broncos are getting ready to get the tight end position involved with the offense again. Both <a href="http://www.sports-reference.com/cfb/search/search.fcgi?pid=mike-mccoy-5,mike-mccoy-2,mike-mccoy-4&amp;search=Mike+McCoy&amp;utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Mike McCoy</a> and <a href="http://www.sports-reference.com/cfb/players/bill-musgrave-1.html?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Bill Musgrave</a> have a history of solid tight end production, and we should expect it to continue in Denver.</p>
<p>The Broncos may view <a href="http://www.sports-reference.com/cfb/players/aj-derby-1.html?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">A.J. Derby</a>, <a href="http://www.pro-football-reference.com/players/G/GreeVi00.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Virgil Green</a> and <a href="http://www.pro-football-reference.com/players/H/HeueJe00.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Jeff Heuerman</a> as a group that can eventually grow and become a productive unit. That being said, it will be hard not to at least glance at free agency, with names like <a href="http://www.pro-football-reference.com/players/B/BennMa00.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Martellus Bennett</a> and <a href="http://www.pro-football-reference.com/players/B/BurtTr01.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Trey Burton</a> available. Alabama tight end <a href="http://www.sports-reference.com/cfb/players/oj-howard-1.html?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">O.J. Howard</a> has a ton of potential. <a href="http://www.sports-reference.com/cfb/players/evan-engram-1.html?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Evan Engram</a> out of Ole Miss has great hands, and could be available with a later pick.</p>
<h2><strong>Inside linebacker</strong></h2>
<p>Yes, the Broncos have inside linebackers that are experienced and still under contract. However, this group struggled mightily this season, and it wouldn’t be a surprise to see Elway go look to shore up the position. Following the loss of <a href="http://www.pro-football-reference.com/players/T/TrevDa00.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Danny Trevathan</a>, Denver plugged in <a href="http://www.pro-football-reference.com/search/search.fcgi?pid=MarsBr00,MarsBr01&amp;search=Brandon+Marshall&amp;utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Brandon Marshall</a>, <a href="http://www.pro-football-reference.com/players/D/DaviTo01.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Todd Davis</a>, <a href="http://www.pro-football-reference.com/players/N/NelsCo00.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Corey Nelson</a> and <a href="http://www.pro-football-reference.com/players/A/AndeZa01.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Zaire Anderson</a>, and saw their run defense get softer. Their safeties forced into making way too many tackles.</p>
<p>Dont’a Hightower has been phenomenal with New England, when he has been healthy, but might carry too big of a price tag. The draft might be a better option. Vanderbilt’s <a href="http://www.sports-reference.com/cfb/players/zach-cunningham-1.html?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow">Zach Cunningham</a> is a tackling machine, and the Broncos could show some interest in him with one of their early picks.</p>

</div></div><div class="theiaPostSlider_footer _footer"></div><p><!-- END THEIA POST SLIDER --></p>

                <script type='text/javascript'>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</script>
            <div class="td-a-rec td-a-rec-id-content_bottom  "><!-- /65792806/728-90_2 -->
<div id='div-gpt-ad-1483478416183-3' style='height:81px; width:655px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1483478416183-3'); });
</script>
</div></div>                <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://milehighsports.com/author/cdaly/">Clint Daly</a></span></div>        <footer></footer>
        <div class="td-post-sharing td-post-sharing-bottom "><span class="td-post-share-title">SHARE</span>
            <div class="td-default-sharing">
	            <a class="td-social-sharing-buttons td-social-facebook" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fmilehighsports.com%2Fpositions-broncos-looking-upgrade-offseason%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Facebook</div></a>
	            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Positions+the+Broncos+should+be+looking+to+upgrade+this+offseason&url=http%3A%2F%2Fmilehighsports.com%2Fpositions-broncos-looking-upgrade-offseason%2F&via=Mile+High+Sports"><i class="td-icon-twitter"></i><div class="td-social-but-text">Twitter</div></a>
	            <a class="td-social-sharing-buttons td-social-google" href="http://plus.google.com/share?url=http://milehighsports.com/positions-broncos-looking-upgrade-offseason/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
	            <a class="td-social-sharing-buttons td-social-pinterest" href="http://pinterest.com/pin/create/button/?url=http://milehighsports.com/positions-broncos-looking-upgrade-offseason/&amp;media=http://milehighsports.com/wp-content/uploads/2017/02/Russell-Okung.jpg&description=Likely to have 10 draft picks and around $33 million dollars to spend, which positions are the Broncos going to be looking to upgrade?" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
	            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Positions+the+Broncos+should+be+looking+to+upgrade+this+offseason%20-%20http%3A%2F%2Fmilehighsports.com%2Fpositions-broncos-looking-upgrade-offseason%2F" ><i class="td-icon-whatsapp"></i></a>
            </div></div>        </div>


        <footer>
            
            <div class="td-post-source-tags">
                                            </div>

	    <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Clint Daly"></span><meta itemprop="datePublished" content="2017-02-10T09:00:22+00:00"><meta itemprop="dateModified" content="2017-02-10T09:01:59+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://milehighsports.com/positions-broncos-looking-upgrade-offseason/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://milehighsports.com/wp-content/uploads/2015/09/mhs_logo_xsm.png"></span><meta itemprop="name" content="Mile High Sports"></span><meta itemprop="headline " content="Positions the Broncos should be looking to upgrade this offseason"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://milehighsports.com/wp-content/uploads/2017/02/Russell-Okung.jpg"><meta itemprop="width" content="900"><meta itemprop="height" content="600"></span>	</footer>
        

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts td_uid_4_589de40964120_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_4_589de40964120" ><script>var block_td_uid_4_589de40964120 = new tdBlock();
block_td_uid_4_589de40964120.id = "td_uid_4_589de40964120";
block_td_uid_4_589de40964120.atts = '{"limit":3,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_4_589de40964120_rand","offset":"","css":"","live_filter":"cur_post_same_categories","live_filter_cur_post_id":97774,"live_filter_cur_post_author":"484"}';
block_td_uid_4_589de40964120.td_column_number = "3";
block_td_uid_4_589de40964120.block_type = "td_block_related_posts";
block_td_uid_4_589de40964120.post_count = "3";
block_td_uid_4_589de40964120.found_posts = "3583";
block_td_uid_4_589de40964120.header_color = "";
block_td_uid_4_589de40964120.ajax_pagination_infinite_stop = "";
block_td_uid_4_589de40964120.max_num_pages = "1195";
tdBlocksArray.push(block_td_uid_4_589de40964120);
</script><h4 class="td-related-title"><a id="td_uid_5_589de409677cd" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_4_589de40964120" href="#">RELATED ARTICLES</a><a id="td_uid_6_589de4096780e" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_4_589de40964120" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_4_589de40964120 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://milehighsports.com/highlights-george-king-scores-21-buffs-beat-huskies/" rel="bookmark" title="HIGHLIGHTS: George King scores 21 as Buffs beat Huskies"><img width="218" height="150" class="entry-thumb" src="http://milehighsports.com/wp-content/uploads/2017/02/USATSI_9868766_164063748_lowres-218x150.jpg" alt="" title="HIGHLIGHTS: George King scores 21 as Buffs beat Huskies"/></a></div>                <a href="http://milehighsports.com/category/teams/buffs/" class="td-post-category">Buffs</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://milehighsports.com/highlights-george-king-scores-21-buffs-beat-huskies/" rel="bookmark" title="HIGHLIGHTS: George King scores 21 as Buffs beat Huskies">HIGHLIGHTS: George King scores 21 as Buffs beat Huskies</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://milehighsports.com/highlights-penguins-skate-past-avs-4-1-pepsi-center/" rel="bookmark" title="HIGHLIGHTS: Penguins skate past Avs, 4-1, at Pepsi Center"><img width="218" height="150" class="entry-thumb" src="http://milehighsports.com/wp-content/uploads/2017/02/USATSI_9868878_164063748_lowres-218x150.jpg" alt="" title="HIGHLIGHTS: Penguins skate past Avs, 4-1, at Pepsi Center"/></a></div>                <a href="http://milehighsports.com/category/teams/colorado-avalanche/" class="td-post-category">Avalanche</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://milehighsports.com/highlights-penguins-skate-past-avs-4-1-pepsi-center/" rel="bookmark" title="HIGHLIGHTS: Penguins skate past Avs, 4-1, at Pepsi Center">HIGHLIGHTS: Penguins skate past Avs, 4-1, at Pepsi Center</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://milehighsports.com/due-respect-jerry-jones-pat-bowlen-deserving-hof/" rel="bookmark" title="With all due respect to Jerry Jones, Pat Bowlen is more deserving of the HOF"><img width="218" height="150" class="entry-thumb" src="http://milehighsports.com/wp-content/uploads/2015/10/USATSI_8158575_164063748_lowres-218x150.jpg" alt="Pat Bowlen" title="With all due respect to Jerry Jones, Pat Bowlen is more deserving of the HOF"/></a></div>                <a href="http://milehighsports.com/category/teams/denver-broncos/" class="td-post-category">Broncos</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://milehighsports.com/due-respect-jerry-jones-pat-bowlen-deserving-hof/" rel="bookmark" title="With all due respect to Jerry Jones, Pat Bowlen is more deserving of the HOF">With all due respect to Jerry Jones, Pat Bowlen is more deserving of the HOF</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_589de40964120" data-td_block_id="td_uid_4_589de40964120"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_589de40964120" data-td_block_id="td_uid_4_589de40964120"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
        <div class="td-a-rec td-a-rec-id-content_bottom  "><!-- /65792806/728-90_2 -->
<div id='div-gpt-ad-1483478416183-3' style='height:81px; width:655px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1483478416183-3'); });
</script>
</div></div>
<!-- BEGIN SendtoNews -->

<div class='s2nPlayer-G799I94q' data-type='full'></div><script type='text/javascript' src='http://embed.sendtonews.com/player2/embedcode.php?fk=G799I94q&cid=7121' data-type='s2nScript'></script>

<!-- END SendtoNews -->

<!-- BEGIN audioBoom -->

<iframe width="100%" height="350" style="background-color:transparent; display:block; max-width: 700px;" frameborder="0" allowtransparency="allowtransparency" scrolling="no" src="//embeds.audioboom.com/publishing/playlist/v4?bg_fill_col=%23ecefef&amp;boo_content_type=channel&amp;data_for_content_type=4902415&amp;image_option=small&amp;link_color=%2358d1eb&amp;player_theme=light&amp;src=https%3A%2F%2Fapi.audioboom.com%2Fchannels%2F4902415%2Faudio_clips%3Finclude_child_channels%3D1" title="audioBoom player"></iframe>

<!-- END audioBoom -->

<!-- BEGIN Content.ad -->
<div id="contentad179672"></div>
<script type="text/javascript">
    (function(d) {
        var params =
        {
            id: "09803d76-26a5-4871-a3ef-13b66a0778d1",
            d:  "bWlsZWhpZ2hzcG9ydHMuY29t",
            wid: "179672",
            cb: (new Date()).getTime()
        };

        var qs=[];
        for(var key in params) qs.push(key+'='+encodeURIComponent(params[key]));
        var s = d.createElement('script');s.type='text/javascript';s.async=true;
        var p = 'https:' == document.location.protocol ? 'https' : 'http';
        s.src = p + "://api.content.ad/Scripts/widget2.aspx?" + qs.join('&');
        d.getElementById("contentad179672").appendChild(s);
    })(document);
</script>
<!-- END Content.ad -->
<!-- BEGIN Content.ad mobile -->
<div id="contentad179673"></div>
<script type="text/javascript">
    (function(d) {
        var params =
        {
            id: "fa6e50b6-5c2f-4024-9bcf-416845b5b0cb",
            d:  "bWlsZWhpZ2hzcG9ydHMuY29t",
            wid: "179673",
            exitPopMobile: true,
            cb: (new Date()).getTime()
        };

        var qs=[];
        for(var key in params) qs.push(key+'='+encodeURIComponent(params[key]));
        var s = d.createElement('script');s.type='text/javascript';s.async=true;
        var p = 'https:' == document.location.protocol ? 'https' : 'http';
        s.src = p + "://api.content.ad/Scripts/widget2.aspx?" + qs.join('&');
        d.getElementById("contentad179673").appendChild(s);
    })(document);
</script>
<!-- END Content.ad mobile -->



<div id="disqus_thread">
    </div>

                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside class="widget widget_text">			<div class="textwidget"><a href="javascript:;" onclick="javascript:window.open('http://v6.player.abacast.net/3526','ppv5','height=530,width=800,menubar=no,scrollbars=no,toolbar=no,status=no,resizable=no')"><img src="http://milehighsports.com/wp-content/uploads/2016/04/Listen_LiveAM_FM.jpg" border="0"></a></div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- MHS_300x600 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-5774454645204961"
     data-ad-slot="3981796337"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><!-- /65792806/300-250_1 -->
<div id='div-gpt-ad-1483478416183-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1483478416183-0'); });
</script>
</div></div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- MHS_300x250 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-5774454645204961"
     data-ad-slot="4165001535"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><!-- /65792806/300-250_3 -->
<div id='div-gpt-ad-1483478416183-1' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1483478416183-1'); });
</script>
</div></div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><a href="http://milehighsports.com/subscribe-daily/"><img src="http://milehighsports.com/wp-content/uploads/2015/09/daily_noborder.jpeg" alt="Daily Signup" /></a></div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- MHS_300x250 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-5774454645204961"
     data-ad-slot="4165001535"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- MHS_300x250 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-5774454645204961"
     data-ad-slot="4165001535"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- MHS_300x250 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-5774454645204961"
     data-ad-slot="4165001535"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- MHS_300x600 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-5774454645204961"
     data-ad-slot="3981796337"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Footer -->


<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-mhs-footer-container"><ul id="menu-mhs-footer" class="td-subfooter-menu"><li id="menu-item-62167" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-62167"><a target="_blank" href="http://v6.player.abacast.net/3526">LISTEN LIVE</a></li>
<li id="menu-item-62211" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-62211"><a href="http://milehighsports.com/subscribe/">SUBSCRIBE</a></li>
<li id="menu-item-62218" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-62218"><a href="http://milehighsports.com/subscribe-daily/">DAILY SIGNUP</a></li>
<li id="menu-item-62166" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-62166"><a href="http://milehighsports.com/lineup/">RADIO LINEUP</a></li>
<li id="menu-item-62164" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-62164"><a href="http://milehighsports.com/current-issue/">MAGAZINE</a></li>
<li id="menu-item-62168" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-62168"><a href="http://milehighsports.com/podcasts/">PODCASTS</a></li>
<li id="menu-item-62306" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-62306"><a href="/daily-column/">DAILY COLUMN</a></li>
<li id="menu-item-63589" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-63589"><a href="http://milehighsports.com/contact/">CONTACT</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                                    </div>
            </div>
        </div>
    </div>
    </div><!--close content div-->
</div><!--close td-outer-wrap-->



    <!--

        Theme: Newspaper by tagDiv 2016
        Version: 7.2 (rara)
        Deploy mode: deploy
        Speed booster: v4.1

        uid: 589de4096f3b7
    -->

    
<!-- Custom css form theme panel -->
<style type="text/css" media="screen">
/* custom css theme panel */
input#gform_submit_button_1 {
    width: 300px;
}
div#td-aj-search {
    display: none;
}


.gform_heading {
    display: none;
}

</style>

<script type='text/javascript' src='http://milehighsports.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='http://milehighsports.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.6.1'></script>
<script type='text/javascript' src='http://milehighsports.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=7.2'></script>
<script type='text/javascript' src='http://milehighsports.com/wp-includes/js/comment-reply.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://milehighsports.com/wp-includes/js/wp-embed.js?ver=4.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.7.2","language":""},"disqusIdentifier":"97774 http:\/\/milehighsports.com\/?p=97774","disqusShortname":"mhsports","disqusTitle":"Positions the Broncos should be looking to upgrade this offseason","disqusUrl":"http:\/\/milehighsports.com\/positions-broncos-looking-upgrade-offseason\/","options":{"manualSync":"1"},"postId":"97774"};
/* ]]> */
</script>
<script type='text/javascript' src='http://milehighsports.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"mhsports"};
/* ]]> */
</script>
<script type='text/javascript' src='http://milehighsports.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=4.7.2'></script>

<!-- JS generated by theme -->

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://milehighsports.com/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://milehighsports.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>


<!-- Header style compiled by theme -->

<style>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</style>


</body>
</html>